Discussione:
Problemino con JVCL
(troppo vecchio per rispondere)
Daniele
2021-03-12 09:13:56 UTC
Permalink
Ciao a tutti,
ho un piccolo problemino con l'installazione delle JVCL.

Prima dell'installazione delle Jvcl caricavo, nel componente TImage,le
gif animate e venivano riconosciute come TGifImage.

Dopo l'installazione delle Jvcl quando carico le gif animate esse
vengono salvate come TJvGifImage.

Ora, per ricaricare l'iimagine come GifImage devo disinstallare JVcl
(solo per quel progetto) e poi, per gli altri progetti, reinstallarle.


Non c'e' un modo per escludere da quell'unico progetto le jvcl ??
Sembra che le Jvcl "scavalchino" le unit di delphi.

Problema banale dal quale non so come uscire ....

Vi ringrazio per l'aiuto ...

Ciao
Daniele

Delphi 10.4.1
Windiws 10 64 bit
Progetto compilato 32 bit
Alessandro B.
2021-03-13 08:39:06 UTC
Permalink
Post by Daniele
Ciao a tutti,
ho un piccolo problemino con l'installazione delle JVCL.
Prima dell'installazione delle Jvcl caricavo, nel componente TImage,le
gif animate e venivano riconosciute come TGifImage.
Dopo l'installazione delle Jvcl quando carico le gif animate esse
vengono salvate come TJvGifImage.
Ora, per ricaricare l'iimagine come GifImage devo disinstallare JVcl
(solo per quel progetto) e poi, per gli altri progetti, reinstallarle.
Non c'e' un modo per escludere da quell'unico progetto le jvcl ??
Sembra che le Jvcl "scavalchino" le unit di delphi.
Problema banale dal quale non so come uscire ....
Vi ringrazio per l'aiuto ...
Ciao
Daniele
Delphi 10.4.1
Windiws 10 64 bit
Progetto compilato 32 bit
Premesso che non uso le Jvcl,
hai provato a invertire nelle sezioni uses le unit ?
Oppure a creare l'oggetto gifimage specificando
davanti al nome anche la unit dove è dichiarato?
Daniele
2021-03-15 09:56:45 UTC
Permalink
Ciao, grazie per la risposta
Post by Alessandro B.
Premesso che non uso le Jvcl,
hai provato a invertire nelle sezioni uses le unit ?
Oppure a creare l'oggetto gifimage specificando
davanti al nome anche la unit dove è dichiarato?
Quando le jvcl sono installate nelle uses si aggiunge da solo il file
dove e' presente il componente TJvGifImage.

Non ho mai avuto un problema simile ... probabilmente mi sfugge qualcosa
durante l'installazione delle jvcl.

Grazie ancora

Ciao
Daniele

Continua a leggere su narkive:
Loading...